Start a new topic

Vortex editor 3d interface white screen


I am a student from Italy and I had installed the Vortex Studio essentials recently, but the editor pops up with a white screen.

My System Configuration is:

Intel i7 (3rd Gen)

AMD 7670HDM Graphics card


The 3d interface is not showing, I had updated the graphics driver and still, it doesn't work. Is the problem associated with OpenGL/Graphics libraries? Any feedback would be of great help.

(133 KB)

Hi Vishal,

Your graphics card is 6 years old, I am not sure that this graphics card is strong enough to support vortex studio. I will do my best to help on this.

I have some questions for you:

  • Which version of Vortex Studio are you using? (2018a or 2017c)?
  • Which version of AMD driver are you using?
  • Which CPU are you using? You mentioned Intel i7, can you give the specific number? e.g. Mine is i7-6700
If you have hard time to find answers to my questions, You can just send me the log file of your Vortex Studio.
To do this, you can type %temp% in your windows search, and in that folder you should be able to find a file named VortexEditor_wks00188_12240.log (numbers would be different, but the rest of file name should be the same). I can find answers in that file.

Hi Jia,


1. Vortex Studio Editor 2017b

2.  AMD Radeon 7670M HD, Catalyst Control Center 15.7.1

3. i7-3612 QM 2.1 GHz 4GB Installed RAM

I have enclosed two log files.


Hi Vishal,

As I suspected, your laptop is running Vortex Studio with Intel Graphics chip. The latest version of Vortex Studio need support of OpenGL 4.3 and your Intel Graphics chip supports only version 3.3.

The good news is your AMD graphics card should support OpenGL 4.3. So if you can enable it, Vortex should work. 

Following link will help you to set your default graphics card.

Changing graphics card settings to use your dedicated GPU on a Windows computer.

2 people like this

Hi Jia,

That's great. I tried this but when I set the application to high performance manually in AMD Properties, and open it, it crashes showing the executable stopped working whereas when I switch back to Power saving it opens up with the white screen. 

(51.1 KB)

Can you give me your log file again? The one you get when you got the crash, not the one when you get the whit screen.

Enclosed are the log files for your perusal.


In your editor log file, it mentions that you are still running on intel graphics chipset. You can read the log file yourself and looking for the section "Graphics Capabilities"

Gpu: intel intel(r) hd graphics 4000


OpenGL: 3.3.0

Mine is saying Gpu: amd amd radeon hd 7700 series.

Some how you need to force your laptop to use AMD chipset when you run Vortex Studio.

Following is what I find on tom's hardware discussion forum. It looks very similar to your problem.

The several suggestions in all the replies. You can try them and see if it work for you.

Yes, I noticed that from the log file and tried to switch. Actually, when I switch PTC Creo 3D or Solidworks to High Performance in AMD Chipset, it does display high performance during startup and works fine. Although, Vortex Editor is not able to start even though I switch it to Radeon 7670M, by default it takes Intel 4000. Does it require more RAM as well, as I am using the installed 4GB RAM to run it? The forum doesn't solve it, I will let you know once I find a workaround. Thanks a ton.

Login to post a comment