Start a new topic

Use Numpy within Vortex Editor

Dear all,

I have a question regarding the external distribution of Python using in Vortex. I tried to use the module numpy within Python, but did not succeed to use it. In Anaconda I can use the Numpy module but in Vortex not.


The version of Python I use within Vortex is: 2.7.13 |Anaconda custom (64-bit)| (default, Sep 30 2017, 11:12:42) [MSC v.1500 64 bit (AMD64)]


The error I get in Vortex:

Traceback (most recent call last):

File "<string>", line 22, in <module>

File "c:\ProgramData\Anaconda2\Lib\site-packages\numpy\", line 142, in <module>

from . import add_newdocs

File "c:\ProgramData\Anaconda2\Lib\site-packages\numpy\", line 13, in <module>

from numpy.lib import add_newdoc

File "c:\ProgramData\Anaconda2\Lib\site-packages\numpy\lib\", line 8, in <module>

from .type_check import *

File "c:\ProgramData\Anaconda2\Lib\site-packages\numpy\lib\", line 11, in <module>

import numpy.core.numeric as _nx

File "c:\ProgramData\Anaconda2\Lib\site-packages\numpy\core\", line 26, in <module>

raise ImportError(msg)



Importing the multiarray numpy extension module failed. Most

likely you are trying to import a failed build of numpy.

If you're working with a numpy git repo, try `git clean -xdf` (removes all

files not under version control). Otherwise reinstall numpy.

Original error was: DLL load failed: The specified module could not be found.


So the numpy module is found by Vortex, but I still get the above error.


Can you help me finding a solution for this problem?



Jauke van den Brink

Hi Jauke,

Here is some information for using Python with Vortex Studio:

For your case:

Vortex 2018a should work with Anaconda, so Python 2.7.13 and numpy 1.11.3.

See also here:



Please tell me about the following error handling.

ImportError: No module named numpy 


I set the environment of the following URL to use Numpy with Vortex.


However, Numpy cannot be used.

Vortex is used in the following environment.

- Windows 1064bit

- Vortex Studio Editor 2020a

- Python 2.7.13

- Anaconda 4.3.0 (64-bit)


I have confirmed the following settings.

- Delete “python27.dll” from “C:\CM Labs\Vortex Studio 2020a\bin”

- Setting environment variables


Also, I confirmed that the “python27.dll” on the “C:\Users\***** \Anaconda2” was read correctly.


Are there any items other than the above that need to be set or confirmed?

Can you help me please?




We will support this in Python 3, available in our new version of Vortex Studio 2020b, coming out before the end of the year. 

Thank you for contacting us about this issue.


Login to post a comment