Start a new topic

ABI compatibility in Linux (Ubuntu)

Hi,


I was trying to compile a small program and link with the VxCore and VxPlatform library using gcc 5.7 in Ubuntu 18.04 and my simple application was crashing.


This was due to an incompatibility in the ABI of gcc between the different version


Finally I was able to fix the problem by using this flag  ( -D_GLIBCXX_USE_CXX11_ABI=0 ) for  g++.


g++  -D_GLIBCXX_USE_CXX11_ABI=0 simple_code.cpp -lVxCore -lVxPlatform -I/vortex/include -L/vortex/lib


Hope this help someone else.


Remi


1 person likes this idea
Login to post a comment