Start a new topic

Automatic Transmission Logic

Hello,


I have created a vehicle mechanism (sports car) and set all the dynamics parameters properly, including the gear ratios. However, when I set the lever position to D1 in the Automatic  Transmission Logic and play the simulation the vehicle does not change to upper gear. What do I have to do in this situation?




Hello,


The Lever Position has several standard positions:

P = park

R = reverse

N = neutral

D = drive (forward)


But you can also limit the shifting to a certain range using the following examples:

D1 = forward, but only 1st gear

D2D5 = forward, but only between 2nd and 5th gear


So if you specified D1, that means forward gear, but prevented from shifting higher than 1st gear. Maybe what you want is just D.


1 person likes this

Thank you, Martin.


I have also tried the "D" mode, however it still does not change the gears. I attached below the speed plot of a straight line simulation and also the specifications and outputs that are appearing here.


image


PARAMETERS:


image



INPUT:


image


OUTPUT:


image




Hi José,


The gear ratios look fine, so the next thing to check would be the gear shift points, in Inputs -> Automatic Transmission:

Gear Change Up

Gear Change Down

Gear Quick Change Up

Gear Quick Change Down


These are the points at which the transmission will automatically shift up and down. They're normalized to be between 0 and 1, as a ratio of maximum RPM. 


For example, if the engine has a maximum RPM of 2000, and the Gear Change Up is 0.9, the transmission will up-shift when the RPM reaches 1800. 


The 'Quick' fields are equivalent, but they are used when throttle is near maximum (I think around 0.95 or higher). This allows you to have a different shifting schedule at low and high throttle positions.


One important thing to note, though, is that the RPM that determines when to shift is the transmission input shaft (or torque converter output), so it is not exactly the RPM of the engine. Particularly if the torque converter is slipping a lot, the transmission input shaft RPM could be much lower than the engine RPM, and the shift could happen later than expected. 


If the slip is high and the shift point it high, the transmission might never shift. This could be what's happening to you. To check this, you need to check the value in Outputs -> Torque Converter -> Output Shaft RPM, rather than the engine RPM. 



1 person likes this

Thank you very much, Martin.


Now it's working well (see the speed plot below)! I just had to adjust the values of Gear Change Up and Gear Quick Ghange Up. The problem was that those values were to high for the Engine Model and Torque Converter Model that I am using.


image


Excellent! I'm glad it's working!

Login to post a comment